Site down
Incident Report for Futureproofs
Postmortem

The root cause of last night's site outage was issues with the Elastic Load Balancer (which spreads requests from users across our application servers, to stop any one machine getting overloaded). The application servers themselves seem to have been working fine, but the ELB was intermittently returning an error instead of passing requests on to the servers.

The issue is resolved and we are improving our instrumentation to ensure that we have more information on this kind of error if it happens again. (Fortunately, one of our existing monitoring services already picked up the error, but more detail helps us to diagnose and resolve specific causes.)

Again, I'm very sorry that we let you down and will work hard to keep you working reliably in the future.

Posted over 3 years ago. Jan 18, 2016 - 09:31 GMT

Resolved
The site was down from 10pm-midnight on Sunday 17 January. The situation is resolved and we are monitoring to avoid further issues (see the postmortem for more detail). I'm very sorry if you tried to work during this time, and we'll do our best to avoid similar issues in the future.
Posted over 3 years ago. Jan 18, 2016 - 08:30 GMT