System problems
Incident Report for Futureproofs
Resolved
The server responsible is now up and running again with its upgrades in place, and so Futureproofs is working again as normal. We're very sorry about this interruption, and will be working with our supplier to prevent this happening again.

(For those who want the technical details, the affected server runs our RabbitMQ queue, which makes sure that all tasks that don't happen immediately nonetheless happen as they should - file conversions, emails and, crucially, application logging. Unfortunately, because the queue server went down without warning, our application started timing out on all its attempts to log things like markup creation. This led to errors and apparent failures of user interactions, even though markup was actually being created as normal - it was the return message that was failing. which signals to the application that the information's been saved.)
Posted 7 months ago. Oct 25, 2018 - 16:41 BST
Identified
One of our providers is doing an unannounced upgrade and reboot of one of the servers we use, which has had a cascading effect on the Futureproofs application. There's nothing we can do to expedite this process, unfortunately, but we're keeping an eye on it and hope that our current problems will resolve themselves once their upgrade is complete.
Posted 7 months ago. Oct 25, 2018 - 15:07 BST
Investigating
The application is partially unavailable at present - although users can log in and view documents, and changes to markup are being saved, these are not being reported back to the user and errors are being generated. We are investigating and will update once we have more information.
We're very sorry for the inconvenience.
Posted 7 months ago. Oct 25, 2018 - 11:04 BST
This incident affected: Our servers (Our application server).